【安全预警】Linux 内核远程拒绝服务漏洞

2017-07-07 12:59:43
Dear user
您好!近日,Linux内核被曝存在影响诸多版本的DoS漏洞(CVE-2017-7645),该漏洞是继“Phoenix Talon”(CVE-2017-8890、CVE-2017-9075、CVE-2017-9076、CVE-2017-9077)漏洞之后爆发的另外一个内核远程DoS漏洞,攻击者利用该漏洞可构造长参数发送给NFS服务导致内存越界访问,从而导致系统内核崩溃,目前官方已经发布内核补丁。
为避免您的业务受影响,建议您及时开展自查,并尽快推动内部排查和升级更新,详细参见如下指引说明:

漏洞概述
NFS2/3 RPC客户端向NFS服务器发送长数据,其参数被编码后存储在一个内存页的数组里,并且可以使用指针变量访问到。任意长的参数可以使这些指针指向数组之外,并导致内存越界访问,远程攻击者可以使系统内核崩溃。

风险等级:

漏洞影响
攻击者利用这个漏洞,可以为DoS攻击制造条件。

影响版本:
Linux内核 4.10.11及之前版本都受影响
Ubuntu Linux 17.04
Ubuntu Linux 16.04 LTS
Oracle Enterprise Linux 7
Debian Linux 6.0系列 (官方已停止维护)
CentOS7系列

安全版本:
Ubuntu Linux 17.04:升级到4.10.0.22.24版本
Ubuntu Linux 16.04 LTS:升级到4.4.0.79.85版本
CentOS 7系列:升级到3.10.0-514.26.1.el7版本

检测方法:
可通过uname -a命令查看云主机内核版本查看是否在受影响版本内;

修复建议:
目前官方已经发布最新版本,您可以升级到上述【安全版本】来修复该漏洞。操作建议如下:
1. CentOS系列用户:
a)yum clean all && yum makecache,更新软件源
b)yum update kernel -y,更新当前内核版本
c)reboot,重启生效
d)uname -r,检查当前版本是否为上述【安全版本】,如果是,则说明修复成功;
2. Ubuntu系列用户:
a)sudo apt-get update && sudo apt-get install linux-image-generic,进行系统更新
b)sudo reboot,更新后重启系统生效
c)uname -r,检查当前版本是否为上述【安全版本】,如果是,则说明修复成功;

相关参考:
https://www.ubuntu.com/usn/usn-3312-1/
https://www.ubuntu.com/usn/usn-3314-1/
https://access.redhat.com/errata/RHSA-2017:1615

JD Cloud team

2017-07-07 12:59:43

This content does not have an English version, but a Chinese version, as shown below.

Do not show this message again.
×